Апр 172012
 

При использовании связки zabbix+orabbix для мониторинга ретро-баз (9i), в логе orabbix можно увидеть вот такие ошибки:

2012-04-17 18:24:01,157 [pool-1-thread-14] WARN Orabbix - Error while executing ->dbversion- on database ->mydb- Exception received ORA-02003: invalid USERENV parameter

2012-04-17 18:24:01,157 [pool-1-thread-14] ERROR Orabbix - Error on DBEnquiry on query=dbversion on database=mydb Error returned is java.lang.IllegalArgumentException: null value for key 'dbversion'

Причина такого непотребства в том, что запрос, получающий информацию о версии БД и компонентов, написан для БД 10-й версии и выше. Избавимся от этой проблемы: Continue reading »